• @kevincox@lemmy.ml
    link
    fedilink
    192 months ago

    To be fair having a name can make things easier to read. I get that i % 2 == 0 is a common pattern and most programmers will quickly recognize what is happening. But isEven(i) is just that much easier to grok and leaves that brainpower to work on something else.

    But I would never import a package for it. I would just create a local helper for something this trivial.

    • @NotAViciousCyborg@lemmy.world
      link
      fedilink
      102 months ago

      Exactly what I would do if I had to reuse it, especially now since I know that adding a package would actually add 2. It all just seems so…inefficient

      • @kevincox@lemmy.ml
        link
        fedilink
        112 months ago

        Even if the code isn’t reused adding names to sub-expressions can be very valuable. Often times I introduce new functions or variables even if they are only used once so that I can give them a descriptive name which helps the reader more quickly understand what is happening.

        • @NotAViciousCyborg@lemmy.world
          link
          fedilink
          32 months ago

          Yeah, I do that with pretty much every separate operation in c# since our solutions are pretty big. Most of my JS scripts are just done in ServiceNow which are separated and named appropriately.